Various broken low level quests

Hi there.

I transferred my old character recently and I've been traveling around the realm doing various quests, even low level ones.
Here's a list of quests I couldn't complete.

Character name: Chloise
Server: Ywain4

- Name: Freeing Osier (Level 35)
- Description: [Step #2] Go find Uisetan in Connla in Shannon Estuary.
- Issue: Uisetan doesn't speak. He also doesn't want any of the quest items.

- Name: Search for the Missing Smith (Level 38)
- Description: [Step #8] Return this enchanted ring to Ceard, to help break the enchantment.
- Issue: Giving him the cursed ring makes him say something but the quest doesn't progress (I think he's supposed to die?). The ring doesn't return to the inventory either.

I'll update this list if I come across other incompletable quests.

I tried to talk to the Quest Journalist NPC but it didn't help.
On a side note, it however made some quests repeatable even though the NPC says it's not supposed to be the case, for example:
- Most (all?) of the tutorial quests (book icon).
- [Mag Mell] Steal Away Before the Dawn
- [Tir na mBeo] Laileah' Loss
- Ill Welcomed Guests
These 3 quests have a special quest icon (the DAoC knot but with 3 diamonds around it). Maybe it affects all quests having this icon?


  • edited April 2022 PM
    Turns out you can't edit posts, uh.

    - Name: Piaras and Lhia (level 49)
    - Description: [Step #8] Get the amulet from Piaras.
    - Issue: After giving Piaras the last requested item, he's supposed to finish the amulet and give it to us, but nothing happens and the quest doesn't progress. I was however rewarded some experience.
    Post edited by bm01 on
  • edited April 2022 PM
    - Name: Lost in the Sands of Time (level 48)
    - Description: [Step #14] Destroy Sekhmun before he can join the Setians in their fight against the Mau. [...]
    - Issue: After using the item in step #13 while facing the Necropolis at the correct time and location (where "invis mob for Q502" is), Sekhmun was supposed to spawn, but he didn't. Tried 3 times.
    Post edited by bm01 on
  • 5:
    - Name: Telgar's Redemption (level 48)
    - Description: [Step #9] Now that you have found what you need, give the dart to Barthalos so he might forget talking to you.
    - Issue: Giving the dart to Barthalos removed it from the inventory but didn't progress the quest. Barthalos no longer speak and killing him does nothing.
Sign In or Register to comment.